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1 Overview 

1.1 What is USBSPYDER08? 

The USBSPYDER08 Discovery Kit is a USB-based in-circuit debugger 
specific for Freescale MC9RS08KA, MC9S08QD and MC9S08QG 
microcontrollers. 
USBSPYDER08 comes with a MC9RS08QG4 microcontroller mounted on 
its 8-pin socket. Thanks to the built-in BDM connector, USBSPYDER08 is 
able to debug external MC9RS08KA, MC9S08QD and MC9S08QG devices 
in any package. 
USBSPYDER08 takes advantage of the CodeWarrior Development Studio 
Special Edition (which groups an Editor, Assembler, C Compiler and 
Debugger) and the Freescale BDM interface, which allows the download and 
debug of the user application into the target microcontroller’s Flash memory. 
Together with CodeWarrior, USBSPYDER08 provides you with everything 
you need to write, compile, download, in-circuit emulate and debug user 
code. Full-speed program execution allows you to perform hardware and 
software testing in real time. 
USBSPYDER08 offers you the following debugging features: 
 
� Real-time code execution and in-circuit debugging; 
� Working frequency up to 10 MHz; 
� Socketed target microcontroller; 
� BDM connector for external debugging; 
� 3.3 V devices supported; 
� Jumperless hardware mode setting; 
� USB connection to the PC; 
� CodeWarrior IDE (the same user interface of all Freescale tools), with 

editor, assembler, C compiler and debugger. 
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1.2 Package Contents 

The USBSPYDER08 package includes the following items: 
 
� USBSPYDER08 in-circuit debugging unit; 
� USBSPYDER08 CD-ROM with CodeWarrior Development Studio 

Special Edition, SofTec Microsystems Additional Components and 
documentation. 

1.3 Supported Devices 

USBSPYDER08 supports the following devices: 
 

� MC9RS08KA family; 
� MC9S08QD family; 
� MC9S08QG family. 
 
The on-board socket accepts 8-pin devices, while the provided BDM 
connector can be used to work with external devices in any package. 
Before working with an external target device, you must remove the target 
device mounted on the on-board socket. 

1.4 Hardware Overview 

The USBSPYDER08 Discovery Kit features: 
 
1. A built-in USB to BDM circuitry (based on Freescale MC68HC908JB16 

microcontroller) which allows the host PC to communicate with the 
target microcontroller through a standard USB interface; 

2. A MC9RS08KA, MC9S08QD or MC9S08QG target microcontroller in 8-
pin DIP package, already programmed with a demo application; 

3. A provision for a header connector with all of the microcontroller 
signals; 

4. A BDM connector for debugging external devices. 

6 
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The following figure shows the various USBSPYDER08 connectors. 

 

 

BDM Connector for External Debugging 

USB Connector 
User LED 

On-Board Target Device 

 

USBSPYDER08 Connectors 

1.4.1 USB Connector 
The USB connector is used to connect USBSPYDER08 to the host PC. 
USBSPYDER08 is powered by the USB bus voltage. 

1.4.2 BDM Connector 
USBSPYDER08 uses a variation of the standard, 6-pin BDM connector 
defined by Freescale to program and debug external MC9RS08KA, 
MC9S08QD and MC9S08QG devices, in any package. 
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BKGD
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NC

 
BDM Connector 

Pin Signal Name Description 

1 BKGD Single-wire background interface pin. 

2 GND System ground. 

3 NC Not connected. 

4 RST#/VPP Reset signal to target system, or VPP. 

5 NC Not connected. 

6 VDD By default, this signal is not used by USBSPYDER08. If you want 
to enable this line, you must solder the 0 Ohm R2 resistor (the 
provision for the R2 resistor is placed near the BDM connector). 
With the resistor soldered, the VDD line will supply a power 
voltage to the target (3.3 V). This is used to power on/off the target 
microcontroller in order to force a background monitor mode entry 
when the RST pin is not available. 

BDM Connector Signals 

 

i 
 

Note: before working with an external target device, you 
must remove the target device mounted on the on-board 
socket. 
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1.5 Software Overview 

1.5.1 CodeWarrior Development Studio Special Edition 
USBSPYDER08 comes with CodeWarrior Development Studio Special 
Editions for HC(S)08. 
CodeWarrior Development Studio is a powerful and easy-to-use tool suite 
designed to increase your software development productivity. Its Integrated 
Development Environment (IDE) provides unrivaled features such as 
Processor Expert application design tool, full chip simulation, Data 
Visualization and project manager with templates to help you concentrate on 
the added value of your application. 
The comprehensive, highly visual CodeWarrior Development Studio for 
Freescale Microcontrollers enables you to build and deploy Freescale 
systems quickly and easily. This tool suite provides the capabilities required 
by every engineer in the development cycle, from board bring-up to firmware 
development to final application development. 
Without a license key, the product will run in a 1 KB code-size limited 
demonstration mode. 
To break the 1 KB limit, you have two options: 
 
1. Contact Freescale to request an unlimited period, free license key to 

increase the code size limit to 16 KB; 
2. Contact Freescale to request a 30-day limited, free license key to run 

the compiler without limitations. 
 
This documentation covers the basic setup and operation of CodeWarrior 
Development Studio, but does not cover all of its functions. For further 
information, please refer to the CodeWarrior on-line help and on-line 
documentation provided. 

1.6 Getting Device Samples 

You can obtain free device samples by ordering directly on 
www.freescale.com. 
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1.7 Recommended Reading 

This documentation describes how to use the USBSPYDER08 Discovery Kit 
and how to set up basic debugging sessions with CodeWarrior. Additional 
information can be found in the following documents: 
 
� CodeWarrior additional documentation—available from the 

CodeWarrior IDE. 
� Freescale datasheets. 
� Freescale application notes. 
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2 Quick Start Guide 

2.1 Software Setup 

i 
 

Note: before connecting the USBSPYDER08 board to the 
PC, it is recommended that you install all of the required 
software first (see below), so that the USBSPYDER08 USB 
driver will be automatically found by Windows when you 
connect the board. 

2.1.1 Host System Requirements 
The following hardware and software are required to run the CodeWarrior 
user interface together with USBSPYDER08: 
 

1. A 500-MHz (or higher) PC compatible system running Windows 98, 
Windows 2000 or Windows XP; 

2. 256 MB of available system RAM plus 1 GB of available hard disk 
space; 

3. A USB port; 
4. CD-ROM drive for installation. 

2.1.2 Software Setup 

i 
 

Note: to install the USBSPYDER08 software on Windows 
2000 or Windows XP, you must log in as Administrator. 

 
1. Insert the USBSPYDER08 CD-ROM into your computer’s CD-ROM 

drive. A startup window will automatically appear. 
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2. Choose “Install CodeWarrior” and follow the on-screen instructions. 
3. Choose “Install SofTec Microsystems Additional Components” and 

follow the on-screen instructions. 

2.2 PC Connection 

After installing the software, you can now plug USBSPYDER08 into a USB 
port on your PC. 
USBSPYDER08 is powered by the USB bus voltage, and requires a USB 
port capable of supplying 200 mA. 
The first time USBSPYDER08 is connected to the PC, Windows recognizes 
the instrument and starts the “Found New Hardware Wizard” procedure, 
asking you to specify the driver to use for the instrument. 
 
1. On Windows XP (SP2) the following dialog box will appear, asking you 

to search for a suitable driver on the web. 
 

 
New Hardware Wizard, Step 1 

Select the “No, not this time” option and click the “Next >” button. 
2. The following dialog box will appear. 
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New Hardware Wizard, Step 2 

Click the “Next >” button. 
3. Windows will install the driver files to your system. At the end of the 

installation, the following dialog box will appear. 
 

 
New Hardware Wizard, Step 4 

Click the “Finish” button to exit from the “Found New Hardware 
Wizard” procedure. 

4. The USBSPYDER08 USB driver is now installed on your system. 
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2.3 Moving Your First Steps with CodeWarrior 

1. Start CodeWarrior Development Studio by selecting it in the Windows 
Start menu. 

2. Open the USBSPYDER08 back cover in order to expose the socketed 
microcontroller. 

3. Read the microcontroller code and, from the CodeWarrior main menu, 
choose “File > Open” and select the “demo.mcp” project for your 
specific microcontroller. Projects are placed: 

 
� Under the “\Program Files\Freescale\CodeWarrior for HC08 

V5.1\(CodeWarrior Examples)\HCS08\Evaluation Board 
Examples\USBSPYDER08\” directory for HCS08 devices (QD, 
QG); 

� Under the “\Program Files\Freescale\CodeWarrior for HC08 
V5.1\(CodeWarrior Examples)\RS08\Evaluation Board 
Examples\USBSPYDER08\” directory for RS08 devices (KA). 

 
4. Click “Open”. The “Project” window will open. 
5. The code of this example is contained in either the “main.c” or 

“main.asm” file. Double click on it to open it. 
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CodeWarrior Editor 

6. From the main menu, choose “Project > Debug”. This will compile the 
source code, generate an executable file and download it to 
USBSPYDER08. A new debugger environment will open. 
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CodeWarrior Debugger 

7. From the main menu, choose “Run > Start/Continue”. The program 
will be executed in real-time and will blink the USBSPYDER08 LED. 

8. To stop the program execution, from the main menu choose “Run > 
Halt”. 

9. You can now continue to experiment with the CodeWarrior user 
interface and discover its potentialities (step commands, breakpoints, 
watch windows, etc.) on your own. Please also read carefully the 
additional documentation provided in the USBSPYDER08 CD-ROM. 
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3 Debugging 

3.1 USBSPYDER08 Working Principles 

USBSPYDER08 is an in-circuit debugger—it programs files into the target 
microcontroller and offers debugging features like real-time code execution, 
stepping, and breakpoints. Its debugging features are achieved thanks to the 
microcontroller’s integrated Background Debug Module, BDM (also referred 
to as Background Debug Controller, BDC). 
The BDM peripheral communicates with the host PC board through a 
dedicated, single-wire line (BKGD) of the microcontroller. The same line is 
also used during device programming. 
Contrariwise to traditional in-circuit emulation (where the target application is 
executed and emulated inside the emulator), USBSPYDER08 uses the very 
same target microcontroller to carry on in-circuit execution. This means that 
all microcontroller’s peripherals (timers, A/D converters, I/O pins, etc.) are 
not reconstructed or simulated by an external device, but are the very same 
target microcontroller’s peripherals. Moreover, the USBSPYDER08 
debugging approach ensures that the target microcontroller’s electrical 
characteristics (pull-ups, low-voltage operations, I/O thresholds, etc.) are 
100% guaranteed. 

3.2 Working with CodeWarrior 

3.2.1 Using the Project Wizard to Create Your Application Skeleton 
CodeWarrior helps you get started with your own application by including a 
project wizard specific for USBSPYDER08. 
 
To create a new project with CodeWarrior for the devices supported by 
USBSPYDER08: 
 
1. From the main menu, select “File > New Project…”. 

17 
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2. A dialog box will appear. Choose your target device and select “SofTec 
HCS08” as connection. 

3. Follow the remaining Project Wizard steps. 

3.2.2 Starting your First Debugging Session 
The first time you enter a debugging session (by selecting “Project > 
Debug” from the CodeWarrior’s main menu) the “MCU Configuration” 
dialog box will open, asking you to select the debugging hardware 
connected to the PC. Make sure that the hardware code is set to 
“USBSPYDER08”. 
 

 
The “MCU Configuration” Dialog Box 

3.3 Notes and Tips 

3.3.1 Entering Debug Session with CodeWarrior 
When entering a debug session, the target microcontroller’s Flash memory is 
automatically erased, unsecured, programmed with the user application, and 
the trimming value (if trimming is available for the selected microcontroller) is 
automatically calculated and programmed (in the location suggested by 
Freescale). 
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i 
 

Note: When programming the microcontroller with the user 
application (after having unsecured the device), 
CodeWarrior ignores (doesn’t program) the security bits. As 
a result, when entering a debug session, the device is 
always unsecured, regardless of other user settings. 

3.3.2 Reading Peripheral Status 
Care must be taken when reading some peripheral’s status/data registers, 
since a reading operation may cause the clearing of flags. This may happen 
when the “Memory” window or the “Data” window is open, since these 
windows read microcontroller’s resources during refresh operations. 

3.3.3 Breakpoints and Trace 
CodeWarrior offers a variety of tools for analyzing the program flow: 
breakpoints (both simple and complex), watchpoints and a trace buffer. All 
these features are implemented by taking advantage of the target 
microcontroller’s debug peripheral. 

3.3.4 Breakpoints and BGND Instruction 
The BGND Assembly instruction forces the target microcontroller to enter the 
Active Background Debug mode, stopping program execution. CodeWarrior 
recognizes this event as a breakpoint and updates the contents of registers, 
memory, etc. Successive commands (Start/Continue, Single Step, etc.) will 
continue the execution of the program from the next instruction. 
 

i 
 

Note: the Single Step command (in a C source code) and 
the Step Over and Step Out commands (both in a C and 
Assembly source code) use one hardware breakpoint. 
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3.3.5 Real-Time Memory Update 
During program execution, it is possible to view/edit the contents of the 
“Memory” window and “Data” window in real time (edit operations are only 
available for RAM locations). For example, it is possible to set the periodical 
refresh of the “Memory” window contents by choosing “Mode > 
Periodical” from the pop-up menu which appears by right-clicking on the 
“Memory” window. 

20 
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4 Troubleshooting 

4.1 Common Problems and Solutions 

This section reports some common problems that may arise during general 
use. Please be aware, however, that working with a specific target device 
may cause device-specific issues. 

4.1.1 USB Driver Problems 
If you connected USBSPYDER08 to the PC before installing the 
USBSPYDER08 utilities, the instrument’s USB driver may not have been 
correctly installed on your system. Unplugging and replugging the USB cable 
is of no use, since Windows has marked the device as “disabled”. As a 
consequence, the PC cannot communicate with USBSPYDER08. 
To restore the USB driver (provided the USBSPYDER08 utilities have been 
installed), perform the following steps under Windows XP: 
 
1. Connect USBSPYDER08 to the PC. 
2. Open the Control Panel (“Start > Settings > Control Panel”). 
3. Open the “System” options. 
4. Select the “Hardware” tab. 
5. Click the “Device Manager” button. 
6. The “USBSPYDER08” device will be shown with an exclamation mark 

next to it. Double click on this device. 
7. In the “General” tab, click the “Reinstall Driver” button. Follow the on-

screen instructions. 

4.1.2 Communication Can’t Be Established with USBSPYDER08 
1. If you use USBSPYDER08 to debug an external device, make sure that 

the target board is powered on and the target microcontroller is working. 
Programming and debugging rely on a BDM communication between 
USBSPYDER08 and the target board. This means that, in order to work 

21 
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correctly, the target microcontroller must be running. In particular, make 
sure that: 
 
� The BDM cable is connected to the target board. 
� All of the required BDM signals are correctly tied to the target 

microcontroller. 
 
2. Make sure you are working with the correct hardware model. To 

view/change the hardware model in use in CodeWarrior, choose 
“Connect” from the “SofTec-HCS08” or “SofTec-RS08” menu 
(depending on the target device currently selected) in the CodeWarrior 
debugger window. 

4.1.3 CodeWarrior-Specific: Stepping Execution is Slow 
When the “Memory” window is open, step commands may execute slower, 
since the “Memory” window contents need to be refreshed after every step. 
 
 

22 
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5 Technical Specifications 

Parameter Value 

General  

Operating Voltage 5 V DC (provided by the USB bus) 
 

Power Consumption 200 mA (max) 
 

BDM Section  

BDM connector VDD out signal (pin 6) 3.3 V DC, 100 mA max 

BDM connector BKGD out signal (pin 1) 10 MHz max at 3.3 V DC 

BDM connector VPP out signal (pin 4) 12 V DC, 10 mA max 

Electrical Specifications 

Parameter Value 

Dimensions 83 x 28 x 20 mm 
 

BDM connector type 6-pin, 2.54-mm pitch, dual row header (male) 

Operating temperature 0°C to 50°C 
 

Storage temperature 0°C to 70°C 

Humidity 90% (without condensation) 

Physical and Environmental Specifications

23 
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